Back to overview
Resolved

Emails to Outlook.com/Office 365 blocked by spam filter

Jun 23, 2026 at 6:00am UTC
Affected services
Portal

Resolved
Jun 23, 2026 at 3:26pm UTC

Spamhaus has delisted our email provider, and emails should again arrive. We are closing the incident

Created
Jun 23, 2026 at 6:00am UTC

We are aware of an issue affecting email delivery to Office 365 and Outlook.com subscribers. The issue is on the side of our email provider, Lettermint. Some emails are being blocked, and we are attempting to redeliver any affected messages.

You can follow the incident at our email provider with this link.